好库网 好库网首页 | 我的好库
VC开发指南

Turbo C 2.0集成开发环境的使用(上)-C语言教程

发布者:vchelp
发布日期:2012/6/11 20:36:51   更新日期:2012/6/11 20:36:51
阅读次数:1975
评分:4.80
介绍:我们上机实习和将来考试都是使用Borland Turbo C 2.0这个版本。该系统是DOS操作系统支持下的软件,在windows 环境下,可以在DOS窗口下运行。
正文:

 

1.13 Turbo C 2.0集成开发环境的使用

1.13.1 Turbo C 2.0简介和启动

我们上机实习和将来考试都是使用Borland Turbo C 2.0这个版本。该系统是DOS操作系统支持下的软件,在windows 98环境下,可以在DOS窗口下运行。

我们机房是在D盘根目录下建立一个TC 子目 录下安装Turbo C 2.0系统的。 TC下还建立了两个了目录LIB和INCLUDE, LIB子目录中存放库文件, INCLUDE 子目录中存放所有头文件。

在DOS环境下或在windows 98的DOS窗口下运行运行Turbo C 2.0时, 只要在TC 子目录下键入TC并回车即可进入Turbo C 2. 0 集成开发环境。

在windows 98环境下,也可以选运行菜单,然后键入d:\tc\tc即可,也可以在tc文件夹找到tc.exe文件,然后用鼠标双击该文件名也可进入Turbo C 2. 0 集成开发环境。

Turbo C 是美国Borland 公司的产品,Borland公司是一家专门从事软件开发、研制的大公司。该公司相继推出了一套 Turbo系列软件, 如Turbo  BASIC,  TurboPascal, Turbo Prolog, 这些软件很受用户欢迎。该公司在1987年首次推出TurboC 1.0 产品, 其中使用了全然一新的集成开发环境, 即使用了一系列下拉式菜单, 将文本编辑、程序编译、连接以及程序运行一体化, 大大方便了程序的开发。1988年, Borland 公司又推出Turbo C1.5版本, 增加了图形库和文本窗口函数库等, 而Turbo C 2.0 则是该公司1989年出版的。Turbo C2.0在原来集成开发环境的基础上增加了查错功能, 并可以在Tiny模式下直接生成.COM (数据、代码、堆栈处在同一64K 内存中) 文件。还可对数学协处理器 (支持8087/80287/80387等)进行仿真。

 Borland公司后来又推出了面向对象的程序软件包Turbo C++,它继承发展Turbo C 2.0 的集成开发环境, 并包含了面向对象的基本思想和设计方法。1991年为了适用Microsoft 公司的Windows 3.0 版本, Borland 公司又将Turbo C++ 作了更新, 即Turbo C 的新一代产品Borlandc C++也已经问世了。

1.13.2 Turbo C 2.0集成开发环境

进入Turbo C 2.0集成开发环境中后, 屏幕上显示:

其中顶上一行为Turbo C 2.0 主菜单,  中间窗口为编辑区,  接下来是信息窗 口, 最底下一行为参考行。这四个窗口构成了Turbo C 2.0的主屏幕, 以后的编程、 编译、调试以及运行都将在这个主屏幕中进行。

主菜单在Turbo C 2.0主屏幕顶上一行, 显示下列内容:

File  Edit  Run  Compile  Project  Options  Debug  Break/watch

除Edit外, 其它各项均有子菜单, 只要用Alt加上某项中第一个字母, 就可进入该项的子菜单中。

1.13.3 File菜单

按Alt+F可进入File菜单, 如图:

 

File菜单的子菜单共有9项,分别叙述如下:

1. Load:装入一个文件, 可用类似DOS的通配符(如*.C)来进行列表选择。也可装入其它扩展名的文件, 只要给出文件名(或只给路径)即可。该项的热键为F3, 即只要按F3即可进入该项, 而不需要先进入File菜单再选此项。

2. Pick:将最近装入编辑窗口的8个文件列成一个表让用户选择,  选择后将该程序装入编辑区, 并将光标置在上次修改过的地方。其热健为Alt-F3。

3. New:新建文件, 缺省文件名为NONAME.C, 存盘时可改名。

4. Save:将编辑区中的文件存盘, 若文件名是NONAME.C时, 将询问是否更改文件名, 其热键为F2。

5. Write to:可由用户给出文件名将编辑区中的文件存盘, 若该文件已存在, 则询问要不要 覆盖。

6. Directory:显示目录及目录中的文件, 并可由用户选择。

7. Change dir:显示当前默认目录, 用户可以改变默认目录。

8. Os shell:暂时退出Turbo C 2.0到DOS提示符下,   此时可以运行DOS 命令,   若想回到 Turbo C 2.0中, 只要在DOS状态下键入EXIT即可。

9. Quit:退出Turbo C 2.0, 返回到DOS操作系统中, 其热键为Alt+X。 

说明:

以上各项可用光标键移动色棒进行选择, 回车则执行。也可用每一项的第一个大写字母直接选择。若要退到主菜单或从它的下一级菜单列表框退回均可用Esc键, Turbo C 2.0所有菜单均采用这种方法进行操作, 以下不再说明。

1.13.4 Edit菜单

按Alt+E可进入编辑菜单, 若再回车, 则光标出现在编辑窗口,  此时用户可以 进行文本编辑。编辑方法基本与wordstar相同, 可用F1键获得有关编辑方法的帮助信息。

1. 与编辑有关的功能键如下:

F1        获得Turbo C 2.0编辑命令的帮助信息;

F5        扩大编辑窗口到整个屏幕;

F6        在编辑窗口与信息窗口之间进行切换;

F10       从编辑窗口转到主菜单。

2. 编辑命令简介:

PageUp    向前翻页

PageDn    向后翻页

Home      将光标移到所在行的开始

End       将光标移到所在行的结尾

Ctrl+Y    删除光标所在的一行

Ctrl+T    删除光标所在处的一个词

Ctrl+KB   设置块开始

Ctrl+KK   设置块结尾

Ctrl+KV   块移动

Ctrl+KC   块拷贝

Ctrl+KY   块删除

Ctrl+KR   读文件

Ctrl+KW   存文件

Ctrl+KP   块文件打印

Ctrl+F1   如果光标所在处为Turbo C 2.0库函数, 则获得有关该函数的帮助信息

Ctrl+Q[   查找Turbo C 2.0双界符的后匹配符

Ctrl+Q]   查找Turbo C 2.0双界符的前匹配符 

说明:

1) Turbo C 2.0的双界符包括以下几种符号:

a) 花括符    {和}

b) 尖括符    <和>

c) 圆括符    (和)

d) 方括符    [和]

e) 注释符    /*和*/

f) 双引号    "

g) 单引号    '

2) Turbo C 2.0在编辑文件时还有一种功能, 就是能够自动缩进, 即光标定位和上一个非空字符对齐。在编辑窗口中, Ctrl+OL为自动缩进开关的控制键。

1.13.5 Run菜单

按Alt+R可进入Run菜单, 该菜单有以下各项,如图所示:

 

1. Run:运行由Project/Project name项指定的文件名或当前编辑区的文件。如果对上次编译后的源代码未做过修改, 则直接运行到下一个断点(没有断点则运行到结束)。否则先进行编译、连接后才运行, 其热键为Ctrl+F9。

2. Program reset:中止当前的调试, 释放分给程序的空间, 其热键为Ctrl+F2。

3. Go to cursor::调试程序时使用, 选择该项可使程序运行到光标所在行。光标所在行必须为一条可执行语句, 否则提示错误。其热键为F4。

4. Trace into:在执行一条调用其它用户定义的子函数时, 若用Trace into项, 则执行长条将跟踪到该子函数内部去执行, 其热键为F7。

5. Step over:执行当前函数的下一条语句, 即使用户函数调用, 执行长条也不会跟踪进函数 内部, 其热键为F8。

6. User screen:显示程序运行时在屏幕上显示的结果。其热键为Alt+F5。

1.13.6 Compile菜单

按Alt+C可进入Compile菜单, 该菜单有以下几个内容,如图所示:

 

1. Compile to OBJ:将一个C源文件编译生成.OBJ目标文件,  同时显示生成的文件名。其热键为 Alt+F9。

2. Make EXE file:此命令生成一个.EXE的文件, 并显示生成的.EXE文件名。其中.EXE文件名是下面几项之一:

1) 由Project/Project name说明的项目文件名。

2) 若没有项目文件名, 则由Primary C file说明的源文件。

3) 若以上两项都没有文件名, 则为当前窗口的文件名。

3. Link EXE file:把当前.OBJ文件及库文件连接在一起生成.EXE文件。

4. Build all:重新编译项目里的所有文件, 并进行装配生成.EXE文件。该命令不作过时检查 (上面的几条命令要作过时检查,  即如果目前项目里源文件的日期和时间与目标文件相同或更早, 则拒绝对源文件进行编译)。

5. Primary C file:当在该项中指定了主文件后, 在以后的编译中, 如没有项目文件名则编译此项中规定的主C文件, 如果编译中有错误, 则将此文件调入编辑窗口,  不管目前窗口 中是不是主C文件。

6. Get info:获得有关当前路径、源文件名、源文件字节大小、编译中的错误数目、可用空间等信息,如图:

1.13.7 Project菜单

按Alt+P可进入Project菜单, 该菜单包括以下内容,如图所示:

 

1. Project name:项目名具有.PRJ的扩展名, 其中包括将要编译、连接的文件名。例如有一个程 序由file1.c, file2.c, file3.c组成, 要将这3个文件编译装配成一个file.exe的执行文件, 可以先建立一个file.prj的项目文件, 其内容如下:

     file1.c

     file2.c

     file3.c

此时将file.prj放入Project name项中, 以后进行编译时将自动对项目文件中规定的三个源文件分别进行编译。然后连接成file.exe文件。如果其中有些文件已经编译成.OBJ文件, 而又没有修改过, 可直接写上.OBJ扩 展名。此时将不再编译而只进行连接。

例如:

   file1.obj

file2.c

file3.c

将不对file1.c进行编译, 而直接连接。

说明: 

当项目文件中的每个文件无扩展名时, 均按源文件对待, 另外, 其中的文件也可以是库文件, 但必须写上扩展名.LIB。

2. Break make on:由用户选择是否在有Warining、Errors、Fatal Errors时或Link之前退出Make编译。

3. Auto dependencies:当开关置为on, 编译时将检查源文件与对应的.OBJ文件日期和时间, 否则不进 行检查。

4. Clear project:清除Project/Project name中的项目文件名。

5. Remove messages:把错误信息从信息窗口中清除掉。

 


评论 [发表评论]
账号 密码 还没帐号呢,现在注册一个?

免责声明:好库网所展示的信息由买卖双方自行提供,其真实性、准确性和合法性由信息发布人负责。好库网不提供任何保证,并不承担任何法律责任。